summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 800837c3f..0c894a664 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -68,6 +68,7 @@ if HAVE_CHECK
resolv-tests \
krb5-utils-tests \
check_and_open-tests \
+ ipa_timerules-tests \
files-tests \
refcount-tests \
fail_over-tests
@@ -294,6 +295,7 @@ dist_noinst_HEADERS = \
providers/ldap/sdap_async_private.h \
providers/ipa/ipa_common.h \
providers/ipa/ipa_access.h \
+ providers/ipa/ipa_timerules.h \
tools/tools_util.h \
tools/sss_sync_ops.h \
resolv/async_resolv.h \
@@ -497,6 +499,24 @@ fail_over_tests_LDADD = \
$(SSSD_LIBS) \
$(CHECK_LIBS) \
$(CARES_LIBS)
+
+ipa_timerules_tests_SOURCES = \
+ providers/ipa/ipa_timerules.c \
+ tests/ipa_timerules-tests.c \
+ tests/common.c \
+ $(SSSD_DEBUG_OBJ)
+ipa_timerules_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(POPT_CFLAGS) \
+ $(TALLOC_CFLAGS) \
+ $(PCRE_CFLAGS) \
+ $(CHECK_CFLAGS)
+ipa_timerules_tests_LDADD = \
+ $(POPT_LIBS) \
+ $(PCRE_LIBS) \
+ $(TALLOC_LIBS) \
+ $(CHECK_LIBS)
+
endif
stress_tests_SOURCES = \