summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 6036110bf..8ea773b06 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -88,6 +88,11 @@ libsss_crypt_la_SOURCES = \
libsss_crypt_la_CPPFLAGS = \
$(NSS_CFLAGS)
+if BUILD_PYTHON_BINDINGS
+pyexec_LTLIBRARIES = \
+ pysss.la
+endif
+
###############################
# Global compilation settings #
###############################
@@ -201,6 +206,18 @@ SSSD_LIBS = \
$(NSS_LIBS) \
libsss_crypt.la
+PYTHON_BINDINGS_LIBS = \
+ $(TALLOC_LIBS) \
+ $(TDB_LIBS) \
+ $(TEVENT_LIBS) \
+ $(POPT_LIBS) \
+ $(LDB_LIBS) \
+ $(DBUS_LIBS) \
+ $(REPLACE_LIBS) \
+ $(PCRE_LIBS) \
+ $(NSS_LIBS) \
+ libsss_crypt.la
+
dist_noinst_HEADERS = \
monitor/monitor.h \
util/btreemap.h \
@@ -443,6 +460,7 @@ memberof_la_SOURCES = \
ldb_modules/memberof.c
memberof_la_CFLAGS = \
$(AM_CFLAGS)
+memberof_la_LIBADD = $(LDB_LIBS)
memberof_la_LDFLAGS = \
-avoid-version \
-module
@@ -456,6 +474,22 @@ sssd_krb5_locator_plugin_la_LDFLAGS = \
-avoid-version \
-module
+if BUILD_PYTHON_BINDINGS
+pysss_la_SOURCES = \
+ $(SSSD_UTIL_OBJ) \
+ $(SSSD_TOOLS_OBJ) \
+ python/pysss.c
+pysss_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(PYTHON_CFLAGS)
+pysss_la_LIBADD = \
+ $(PYTHON_BINDINGS_LIBS) \
+ $(PYTHON_LIBS)
+pysss_la_LDFLAGS = \
+ -avoid-version \
+ -module
+endif
+
############
# MANPAGES #
############