summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 45f5eec55..bed9060bd 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -18,6 +18,10 @@ AM_CFLAGS =
if WANT_AUX_INFO
AM_CFLAGS += -aux-info $@.X
endif
+if HAVE_GCC
+ AM_CFLAGS += -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith \
+ -Wcast-qual -Wcast-align -Wwrite-strings
+endif
REPLACE_CFLAGS = \
-I $(srcdir)/../replace