summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index b70be9380..0c5f4674c 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -243,7 +243,9 @@ sssd_be_SOURCES = \
providers/data_provider_be.c \
$(SSSD_UTIL_OBJ)
sssd_be_LDADD = $(SSSD_LIBS)
-sssd_be_LDFLAGS = -export-dynamic
+sssd_be_LDFLAGS = \
+ -Wl,--version-script,$(srcdir)/providers/sssd_be.exports \
+ -export-dynamic
if BUILD_POLICYKIT
sssd_pk_SOURCES = \
@@ -270,7 +272,8 @@ dist_noinst_DATA = \
examples/sssd.conf \
examples/sssdproxylocal \
examples/sssdproxytest \
- examples/sudo
+ examples/sudo \
+ providers/sssd_be.exports
######################
# Command-line Tools #