summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 4ee344bbd..4398259b5 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -52,7 +52,8 @@ sssdlibexec_PROGRAMS = \
if BUILD_TESTS
noinst_PROGRAMS = \
sysdb-tests \
- stress-tests
+ stress-tests \
+ resolv-tests
endif
sssdlib_LTLIBRARIES = \
@@ -328,6 +329,17 @@ stress_tests_SOURCES = \
stress_tests_LDADD = \
$(SSSD_LIBS)
+resolv_tests_SOURCES = \
+ tests/resolv-tests.c \
+ $(SSSD_UTIL_OBJ) \
+ $(SSSD_RESOLV_OBJ)
+resolv_tests_CFLAGS = \
+ $(CHECK_CFLAGS)
+resolv_tests_LDADD = \
+ $(SSSD_LIBS) \
+ $(CHECK_LIBS) \
+ $(CARES_LIBS)
+
endif #BUILD_TESTS
####################