summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 7 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 03070239a..00290e82f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,16 +155,15 @@ m4_include([src/util/signal.m4])
WITH_UNICODE_LIB
if test x$unicode_lib = xlibunistring; then
- m4_include([src/external/libunistring.m4])
- AC_DEFINE_UNQUOTED(HAVE_LIBUNISTRING, 1, [Using libunistring for unicode])
- UNICODE_LIBS=-lunistring
- AC_SUBST(UNICODE_LIBS)
+ m4_include([src/external/libunistring.m4])
+ AC_DEFINE_UNQUOTED(HAVE_LIBUNISTRING, 1, [Using libunistring for unicode])
+ UNICODE_LIBS=$UNISTRING_LIBS
else
- m4_include([src/external/glib.m4])
- AC_DEFINE_UNQUOTED(HAVE_GLIB2, 1, [Using libunistring for unicode])
- UNICODE_LIBS=$GLIB2_LIBS
- AC_SUBST(UNICODE_LIBS)
+ m4_include([src/external/glib.m4])
+ AC_DEFINE_UNQUOTED(HAVE_GLIB2, 1, [Using glib2 for unicode])
+ UNICODE_LIBS=$GLIB2_LIBS
fi
+AC_SUBST(UNICODE_LIBS)
WITH_INITSCRIPT
if test x$initscript = xsystemd; then