summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 3 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index b1e7d85ed..d0785ad78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,6 @@
+m4_include([version.m4])
AC_INIT([sssd],
- m4_esyscmd([cat VERSION |head -n1 | tr -d '\n']),
+ VERSION_NUMBER,
[sssd-devel@lists.fedorahosted.org])
AC_CONFIG_SRCDIR([BUILD.txt])
AC_CONFIG_AUX_DIR([build])
@@ -9,15 +10,8 @@ AC_PROG_INSTALL
AC_CONFIG_SUBDIRS([replace common server sss_client])
-# If the VERSION file has a second line, we'll append it
-# to the release tag when creating an RPM or SRPM
-# This is intended for build systems to create snapshot
-# RPMs. The format should be something like:
-# .20090915gitf1bcde7
-# and would result in an SRPM looking like:
-# sssd-0.5.0-0.20090915gitf1bcde7.fc11.src.rpm
AC_SUBST([PRERELEASE_VERSION],
- m4_esyscmd([cat VERSION |tail --lines=+2 |head -n1 | tr -d '\n']))
+ PRERELEASE_VERSION_NUMBER)
AC_CONFIG_FILES([Makefile contrib/sssd.spec])
AC_OUTPUT