summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d908dbb50..b1e7d85ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,5 +9,15 @@ AC_PROG_INSTALL
AC_CONFIG_SUBDIRS([replace common server sss_client])
+# If the VERSION file has a second line, we'll append it
+# to the release tag when creating an RPM or SRPM
+# This is intended for build systems to create snapshot
+# RPMs. The format should be something like:
+# .20090915gitf1bcde7
+# and would result in an SRPM looking like:
+# sssd-0.5.0-0.20090915gitf1bcde7.fc11.src.rpm
+AC_SUBST([PRERELEASE_VERSION],
+ m4_esyscmd([cat VERSION |tail --lines=+2 |head -n1 | tr -d '\n']))
+
AC_CONFIG_FILES([Makefile contrib/sssd.spec])
AC_OUTPUT