summaryrefslogtreecommitdiffstats
path: root/common/path_utils/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'common/path_utils/configure.ac')
-rw-r--r--common/path_utils/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/common/path_utils/configure.ac b/common/path_utils/configure.ac
new file mode 100644
index 000000000..9207a075b
--- /dev/null
+++ b/common/path_utils/configure.ac
@@ -0,0 +1,18 @@
+AC_INIT([path_utils], [0.1], [jdennis@redhat.com])
+AC_CONFIG_SRCDIR([path_utils.c])
+AC_CONFIG_AUX_DIR([build])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_PROG_CC
+AC_PROG_LIBTOOL
+AC_CONFIG_MACRO_DIR([m4])
+AC_PROG_INSTALL
+
+AM_CONDITIONAL([HAVE_GCC], [test "$ac_cv_prog_gcc" = yes])
+
+m4_pattern_allow([AM_SILENT_RULES])
+AM_SILENT_RULES
+
+AC_CONFIG_HEADERS([config.h])
+
+AC_CONFIG_FILES([Makefile path_utils.pc])
+AC_OUTPUT