summaryrefslogtreecommitdiffstats
path: root/common/ini/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/ini/Makefile.am')
-rw-r--r--common/ini/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/common/ini/Makefile.am b/common/ini/Makefile.am
index 03d891256..dc30e9471 100644
--- a/common/ini/Makefile.am
+++ b/common/ini/Makefile.am
@@ -2,7 +2,16 @@
TRACE_LEVEL=@TRACE_VAR@
topdir=$(srcdir)/..
-AM_CPPFLAGS = -Wall -I$(topdir) -I$(topdir)/trace -I$(topdir)/collection $(TRACE_LEVEL)
+
+AM_CFLAGS =
+if HAVE_GCC
+ AM_CFLAGS += \
+ -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
+ -Wcast-align -Wwrite-strings
+endif
+
+AM_CPPFLAGS = -I$(topdir) -I$(topdir)/trace -I$(topdir)/collection $(TRACE_LEVEL)
+
ACLOCAL_AMFLAGS = -I m4
# Set up the pkg-config file