summaryrefslogtreecommitdiffstats
path: root/common/elapi/elapi_test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/elapi/elapi_test/Makefile.am')
-rw-r--r--common/elapi/elapi_test/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/common/elapi/elapi_test/Makefile.am b/common/elapi/elapi_test/Makefile.am
index b16102c83..cac0ead6d 100644
--- a/common/elapi/elapi_test/Makefile.am
+++ b/common/elapi/elapi_test/Makefile.am
@@ -5,7 +5,8 @@ topdir=$(srcdir)/../..
AM_CFLAGS = -DELAPI_DEFAULT_CONFIG_DIR=\"$(srcdir)\" \
-DELAPI_DEFAULT_CONFIG_APP_DIR=\"$(srcdir)\" \
-DELAPI_DEFAULT_APP_NAME=\"elapi_ut\" \
- -DELAPI_DEFAULT_APP_NAME_SIZE=127
+ -DELAPI_DEFAULT_APP_NAME_SIZE=127 \
+ -DELAPI_UTEST
if HAVE_GCC
AM_CFLAGS += \
@@ -13,26 +14,31 @@ if HAVE_GCC
-Wcast-align -Wwrite-strings
endif
-AM_CPPFLAGS = -I$(topdir) -I$(topdir)/ini -I$(topdir)/trace -I$(topdir)/collection -I$(topdir)/elapi $(TRACE_LEVEL)
+AM_CPPFLAGS = -I$(topdir) -I$(topdir)/ini -I$(topdir)/trace -I$(topdir)/collection -I$(topdir)/elapi \
+ -I$(topdir)/elapi/providers/file $(TRACE_LEVEL)
ACLOCAL_AMFLAGS = -I m4
# Build library
noinst_LTLIBRARIES = libelapi_test.la
+
libelapi_test_la_SOURCES = \
../elapi_event.c \
../elapi_log.c \
../elapi_internal.c \
+ ../elapi_sink.c \
../elapi_event.h \
../elapi_priv.h \
../elapi_sink.h \
../elapi_log.h \
../elapi_async.h \
- ../elapi.h
+ ../elapi.h \
+ ../providers/file/file_provider.c \
+ ../providers/file/file_provider.h
# Build unit test
check_PROGRAMS = elapi_ut
elapi_ut_SOURCES = elapi_ut.c
-elapi_ut_LDADD = libelapi_test.la ../../ini/libini_config.la ../../collection/libcollection.la
+elapi_ut_LDADD = libelapi_test.la ../../ini/libini_config.la ../../collection/libcollection.la -ldl
TESTS = elapi_ut