summaryrefslogtreecommitdiffstats
path: root/common/elapi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/elapi/Makefile.am')
-rw-r--r--common/elapi/Makefile.am26
1 files changed, 18 insertions, 8 deletions
diff --git a/common/elapi/Makefile.am b/common/elapi/Makefile.am
index 2ebf9e833..1fdc9c69e 100644
--- a/common/elapi/Makefile.am
+++ b/common/elapi/Makefile.am
@@ -7,11 +7,13 @@ APP_NAME_SIZE=@appnamesize@
SUBDIRS = elapi_test
topdir=$(srcdir)/..
+prvdrdir=$(srcdir)/providers
-AM_CFLAGS = -DELAPI_DEFAULT_CONFIG_DIR=\"$(DEFAULT_CONF_DIR)\" \
- -DELAPI_DEFAULT_CONFIG_APP_DIR=\"$(DEFAULT_CONF_APP_DIR)\" \
- -DELAPI_DEFAULT_APP_NAME=\"$(APP_NAME)\" \
- -DELAPI_DEFAULT_APP_NAME_SIZE=$(APP_NAME_SIZE)
+AM_CFLAGS = \
+ -DELAPI_DEFAULT_CONFIG_DIR=\"$(DEFAULT_CONF_DIR)\" \
+ -DELAPI_DEFAULT_CONFIG_APP_DIR=\"$(DEFAULT_CONF_APP_DIR)\" \
+ -DELAPI_DEFAULT_APP_NAME=\"$(APP_NAME)\" \
+ -DELAPI_DEFAULT_APP_NAME_SIZE=$(APP_NAME_SIZE)
if HAVE_GCC
AM_CFLAGS += \
@@ -19,7 +21,8 @@ if HAVE_GCC
-Wcast-align -Wwrite-strings
endif
-AM_CPPFLAGS = -I$(topdir) -I$(topdir)/ini -I$(topdir)/trace -I$(topdir)/collection $(TRACE_LEVEL)
+AM_CPPFLAGS = -I$(topdir) -I$(topdir)/ini -I$(topdir)/trace -I$(topdir)/collection \
+ -I$(topdir)/elapi/providers/file $(TRACE_LEVEL)
ACLOCAL_AMFLAGS = -I m4
@@ -27,15 +30,22 @@ ACLOCAL_AMFLAGS = -I m4
pkgconfigdir = $(libdir)/pkgconfig
dist_noinst_DATA = elapi.pc
-# Build library
-noinst_LTLIBRARIES = libelapi.la
+# Build libraries
+noinst_LTLIBRARIES = libprovider.la libelapi.la
+
+libprovider_la_SOURCES = \
+ $(prvdrdir)/file/file_provider.c \
+ $(prvdrdir)/file/file_provider.h
+
libelapi_la_SOURCES = \
elapi_event.c \
elapi_log.c \
elapi_internal.c \
elapi_event.h \
+ elapi_sink.c \
elapi_priv.h \
elapi_sink.h \
elapi_log.h \
elapi_async.h \
- elapi.h
+ elapi.h \
+ ./libprovider.la