summaryrefslogtreecommitdiffstats
path: root/common/dhash/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/dhash/Makefile.am')
-rw-r--r--common/dhash/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/common/dhash/Makefile.am b/common/dhash/Makefile.am
new file mode 100644
index 000000000..d2b92bce2
--- /dev/null
+++ b/common/dhash/Makefile.am
@@ -0,0 +1,15 @@
+AM_CPPFLAGS = -Wall
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = dhash.pc
+
+lib_LTLIBRARIES = libdhash.la
+libdhash_la_SOURCES = dhash.c
+pkginclude_HEADERS = dhash.h
+
+check_PROGRAMS = dhash_test dhash_example
+dhash_test_LDADD = dhash.o
+dhash_example_LDADD = dhash.o
+
+examplesdir = $(docdir)/examples
+dist_examples_DATA = dhash_test.c dhash_example.c