summaryrefslogtreecommitdiffstats
path: root/common/dhash/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/dhash/Makefile.am')
-rw-r--r--common/dhash/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/common/dhash/Makefile.am b/common/dhash/Makefile.am
index 9037bf97c..b8d5ce6ff 100644
--- a/common/dhash/Makefile.am
+++ b/common/dhash/Makefile.am
@@ -1,4 +1,10 @@
-AM_CPPFLAGS = -Wall
+AM_CFLAGS =
+if HAVE_GCC
+ AM_CFLAGS += \
+ -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
+ -Wcast-align -Wwrite-strings
+endif
+
ACLOCAL_AMFLAGS = -I m4
pkgconfigdir = $(libdir)/pkgconfig