summaryrefslogtreecommitdiffstats
path: root/common/dhash/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/dhash/Makefile.am')
-rw-r--r--common/dhash/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/common/dhash/Makefile.am b/common/dhash/Makefile.am
index 67e69b669..9037bf97c 100644
--- a/common/dhash/Makefile.am
+++ b/common/dhash/Makefile.am
@@ -2,15 +2,16 @@ AM_CPPFLAGS = -Wall
ACLOCAL_AMFLAGS = -I m4
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = dhash.pc
+dist_noinst_DATA = dhash.pc
-lib_LTLIBRARIES = libdhash.la
-libdhash_la_SOURCES = dhash.c
-include_HEADERS = dhash.h
+noinst_LTLIBRARIES = libdhash.la
+libdhash_la_SOURCES = \
+ dhash.c \
+ dhash.h
check_PROGRAMS = dhash_test dhash_example
dhash_test_LDADD = dhash.o
dhash_example_LDADD = dhash.o
examplesdir = $(docdir)/examples
-dist_examples_DATA = dhash_test.c dhash_example.c
+dist_noinst_DATA += dhash_test.c dhash_example.c