summaryrefslogtreecommitdiffstats
path: root/common/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'common/configure.ac')
-rw-r--r--common/configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/common/configure.ac b/common/configure.ac
index a5fa3d547..e32139967 100644
--- a/common/configure.ac
+++ b/common/configure.ac
@@ -23,8 +23,17 @@ AC_CONFIG_FILES([Makefile
AC_CONFIG_SUBDIRS([collection dhash ini])
-AC_OUTPUT
-
-
-
+AC_DEFUN([WITH_SINGLELIB],
+ [ AC_ARG_WITH([singlelib],
+ [AC_HELP_STRING([--with-singlelib],
+ [Whether to build a shared object containing all sssd_utils [no]]
+ )
+ ],
+ [],
+ with_singlelib=yes
+ )
+ ])
+
+AM_CONDITIONAL([SINGLELIB], [test x$with_singlelib = xyes ])
+AC_OUTPUT