summaryrefslogtreecommitdiffstats
path: root/common/collection/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'common/collection/configure.ac')
-rw-r--r--common/collection/configure.ac42
1 files changed, 0 insertions, 42 deletions
diff --git a/common/collection/configure.ac b/common/collection/configure.ac
deleted file mode 100644
index 02c0ab4c3..000000000
--- a/common/collection/configure.ac
+++ /dev/null
@@ -1,42 +0,0 @@
-AC_INIT([collection],
- [0.5.0],
- [sssd-devel@lists.fedorahosted.org])
-AC_CONFIG_SRCDIR([collection.c])
-AC_CONFIG_AUX_DIR([build])
-AM_INIT_AUTOMAKE([-Wall -Werror foreign])
-AC_PROG_CC
-AC_PROG_LIBTOOL
-AC_CONFIG_MACRO_DIR([m4])
-AC_PROG_INSTALL
-
-AM_CONDITIONAL([HAVE_GCC], [test "$ac_cv_prog_gcc" = yes])
-
-m4_pattern_allow([AM_SILENT_RULES])
-AM_SILENT_RULES
-
-AC_CONFIG_HEADERS([config.h])
-
-# Enable trace build
-AC_ARG_ENABLE([trace],
- [AS_HELP_STRING([--enable-trace[=LEVEL]],[build with low level tracing enabled])],
- [trace_level="$enableval"],
- [trace_level="0"])
-AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TRACE_VAR],["-DTRACE_LEVEL=$trace_level"])])
-
-AC_CHECK_SIZEOF([long])
-AC_CHECK_SIZEOF([long long])
-
-AC_CHECK_FUNC([strcasestr],
- AC_DEFINE([HAVE_STRCASESTR],
- [1],
- [Define if strcasestr exists]),
- AC_MSG_ERROR("Platform must support strcasestr"))
-
-AC_DEFINE([COL_MAX_DATA], [65535], [Max length of the data block allowed in the collection value.])
-
-AC_PATH_PROG([DOXYGEN], [doxygen], [false])
-AM_CONDITIONAL([HAVE_DOXYGEN], [test x$DOXYGEN != xfalse ])
-
-
-AC_CONFIG_FILES([Makefile collection.cfg.doxy collection.pc])
-AC_OUTPUT