summaryrefslogtreecommitdiffstats
path: root/common/collection/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'common/collection/configure.ac')
-rw-r--r--common/collection/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/common/collection/configure.ac b/common/collection/configure.ac
index 4858bc61f..cf7a1ff3c 100644
--- a/common/collection/configure.ac
+++ b/common/collection/configure.ac
@@ -24,5 +24,12 @@ AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TR
AC_CHECK_SIZEOF([long])
AC_CHECK_SIZEOF([long long])
+AC_CHECK_FUNC([strcasestr],
+ AC_DEFINE([HAVE_STRCASESTR],
+ [1],
+ [Define if strcasestr exists]),
+ AC_MSG_ERROR("Platform must support strcasestr"))
+
+
AC_CONFIG_FILES([Makefile collection.pc])
AC_OUTPUT