summaryrefslogtreecommitdiffstats
path: root/common/collection/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/collection/Makefile.am')
-rw-r--r--common/collection/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/common/collection/Makefile.am b/common/collection/Makefile.am
new file mode 100644
index 000000000..06cf953be
--- /dev/null
+++ b/common/collection/Makefile.am
@@ -0,0 +1,17 @@
+#DEBUG_FLAGS=@DEBUG_VAR@
+TRACE_LEVEL=@TRACE_VAR@
+
+topdir=..
+AM_CPPFLAGS = -I$(topdir) -I$(topdir)/trace $(TRACE_LEVEL)
+
+# Build static libraty
+noinst_LIBRARIES = libcollection.a
+libcollection_a_SOURCES = collection.c collection_tools.c collection.h trace.h collection_tools.h collection_class.h
+
+# Build shared library - reserved for future
+# lib_LTLIBRARIES = libcollection.la
+# libcollection_la_SOURCES = collection.c collection_tools.c collection.h trace.h collection_tools.h collection_class.h
+
+noinst_PROGRAMS = collection_ut
+collection_ut_SOURCES = collection_ut.c
+collection_ut_LDADD = libcollection.a -lm -lz