summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 47d7c4a99..42bd483a1 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -1,19 +1,17 @@
ACLOCAL_AMFLAGS = -I m4
-
+SUBDIRS = trace collection ini dhash
if SINGLELIB
# Build all components as a single shared library
lib_LTLIBRARIES = libsssd_util.la
-libsssd_util_la_SOURCES = \
- collection/collection.c \
- collection/collection_tools.c \
- ini/ini_config.c \
- dhash/dhash.c
+libsssd_util_la_SOURCES =
+libsssd_util_la_LIBADD = \
+ collection/libcollection.la \
+ ini/libini_config.la \
+ dhash/libdhash.la
libsssd_util_la_CFLAGS = $(AM_CFLAGS) \
-I ./collection \
-I ./ini \
-I ./dhash \
-I ./trace
-else
-SUBDIRS = collection ini trace dhash
endif