summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 276bbb2a1..47d7c4a99 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -1,2 +1,19 @@
-SUBDIRS = collection ini trace dhash
ACLOCAL_AMFLAGS = -I m4
+
+if SINGLELIB
+# Build all components as a single shared library
+lib_LTLIBRARIES = libsssd_util.la
+libsssd_util_la_SOURCES = \
+ collection/collection.c \
+ collection/collection_tools.c \
+ ini/ini_config.c \
+ dhash/dhash.c
+libsssd_util_la_CFLAGS = $(AM_CFLAGS) \
+ -I ./collection \
+ -I ./ini \
+ -I ./dhash \
+ -I ./trace
+else
+SUBDIRS = collection ini trace dhash
+endif
+