summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index cefce80c1..067a00a79 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1233,11 +1233,14 @@ if HAVE_DOXYGEN
docs:
$(DOXYGEN) src/doxy.config
$(DOXYGEN) src/providers/ipa/ipa_hbac.doxy
-else
+if BUILD_SUDO
+ $(DOXYGEN) src/sss_client/sudo/sss_sudo.doxy
+endif BUILD_SUDO
+else !HAVE_DOXYGEN
docs:
@echo "Doxygen not installed, cannot generate documentation"
@exit 1
-endif
+endif !HAVE_DOXYGEN
all-local: ldb_mod_test_dir
if BUILD_PYTHON_BINDINGS