summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 07128642f..71d4db710 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,6 +107,7 @@ endif
if HAVE_CHECK
non_interactive_check_based_tests = \
sysdb-tests \
+ sysdb_ssh-tests\
strtonum-tests \
resolv-tests \
krb5-utils-tests \
@@ -780,6 +781,19 @@ sysdb_tests_LDADD = \
libsss_util.la \
libsss_test_common.la
+sysdb_ssh_tests_DEPENDENCIES = \
+ $(ldblib_LTLIBRARIES)
+sysdb_ssh_tests_SOURCES = \
+ src/tests/sysdb_ssh-tests.c
+sysdb_ssh_tests_CFLAGS = \
+ $(AM_CFLAGS)\
+ $(CHECK_CFLAGS)
+sysdb_ssh_tests_LDADD = \
+ $(SSSD_LIBS) \
+ $(CHECK_LIBS) \
+ libsss_util.la \
+ libsss_test_common.la
+
strtonum_tests_SOURCES = \
src/tests/strtonum-tests.c \
src/util/strtonum.c