summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0cc2751fc..1d241d2ba 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1049,6 +1049,12 @@ libsss_ipa_la_LIBADD = \
libsss_ipa_la_LDFLAGS = \
-avoid-version \
-module
+if BUILD_SUDO
+libsss_ipa_la_SOURCES += src/providers/ldap/sdap_sudo_cache.c \
+ src/providers/ldap/sdap_sudo_timer.c \
+ src/providers/ldap/sdap_sudo.c
+endif
+
krb5_child_SOURCES = \
src/providers/krb5/krb5_become_user.c \