summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 27 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b445f9c81..8002bbd0b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,6 +32,7 @@ pipepath = @pipepath@
initdir = @initdir@
logpath = @logpath@
pubconfpath = @pubconfpath@
+pkgconfigdir = $(libdir)/pkgconfig
AM_CFLAGS =
if WANT_AUX_INFO
@@ -43,6 +44,8 @@ if HAVE_GCC
-Werror-implicit-function-declaration
endif
+dist_pkgconfig_DATA =
+
ACLOCAL_AMFLAGS = -I m4 -I .
sbin_PROGRAMS = \
@@ -78,7 +81,8 @@ if HAVE_CHECK
ipa_ldap_opt-tests \
simple_access-tests \
crypto-tests \
- util-tests
+ util-tests \
+ ipa_hbac-tests
endif
check_PROGRAMS = \
@@ -358,6 +362,16 @@ if HAVE_NSS
endif
+lib_LTLIBRARIES = libipa_hbac.la
+dist_pkgconfig_DATA += src/providers/ipa/ipa_hbac.pc
+libipa_hbac_la_SOURCES = \
+ src/providers/ipa/hbac_evaluator.c
+libipa_hbac_la_LDFLAGS = \
+ -version 0:0:0
+
+include_HEADERS = \
+ src/providers/ipa/ipa_hbac.h
+
####################
# Program Binaries #
####################
@@ -695,6 +709,18 @@ crypto_tests_LDADD = \
$(CHECK_LIBS) \
libsss_test_common.la
+ipa_hbac_tests_SOURCES = \
+ src/tests/ipa_hbac-tests.c \
+ $(SSSD_UTIL_OBJ)
+ipa_hbac_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(CHECK_CFLAGS)
+ipa_hbac_tests_LDADD = \
+ $(SSSD_LIBS) \
+ $(CHECK_LIBS) \
+ libsss_test_common.la \
+ libipa_hbac.la
+
endif
stress_tests_SOURCES = \