summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 660b3d40a..ff17b41c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -219,6 +219,7 @@ if HAVE_CMOCKA
test_copy_keytab \
test_child_common \
responder_cache_req-tests \
+ test_sbus_opath \
$(NULL)
if BUILD_IFP
@@ -2208,6 +2209,18 @@ responder_cache_req_tests_LDADD = \
libsss_test_common.la \
$(NULL)
+test_sbus_opath_SOURCES = \
+ src/tests/cmocka/test_sbus_opath.c \
+ $(NULL)
+test_sbus_opath_CFLAGS = \
+ $(AM_CFLAGS)
+test_sbus_opath_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_debug.la \
+ libsss_test_common.la
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client