summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 134c63f03..b90fecec7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -154,6 +154,7 @@ if HAVE_CMOCKA
sss_nss_idmap-tests \
dyndns-tests \
fqnames-tests \
+ nestedgroups-tests \
test_sss_idmap \
test_utils \
ad_access_filter_tests \
@@ -1412,6 +1413,19 @@ fqnames_tests_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+nestedgroups_tests_SOURCES = \
+ $(TEST_MOCK_OBJ) \
+ $(TEST_MOCK_PROVIDER_OBJ) \
+ src/tests/cmocka/test_nested_groups.c \
+ src/providers/ldap/sdap_async_nested_groups.c
+nestedgroups_tests_CFLAGS = \
+ $(AM_CFLAGS)
+nestedgroups_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
+
test_sss_idmap_SOURCES = \
src/tests/cmocka/test_sss_idmap.c
test_sss_idmap_CFLAGS = \