summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 50e3968cb..3475ee09d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -182,6 +182,7 @@ if HAVE_CMOCKA
test_sss_idmap \
test_ipa_idmap \
test_utils \
+ ad_gpo_tests \
ad_common_tests \
dp_opt_tests \
responder-get-domains-tests \
@@ -1776,6 +1777,27 @@ ad_access_filter_tests_LDADD = \
libsss_ad_common.la \
libsss_test_common.la
+ad_gpo_tests_SOURCES = \
+ $(sssd_be_SOURCES) \
+ src/providers/ad/ad_common.c \
+ src/tests/cmocka/test_ad_gpo.c
+ad_gpo_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NDR_NBT_CFLAGS) \
+ -DUNIT_TESTING
+ad_gpo_tests_LDADD = \
+ $(PAM_LIBS) \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(CARES_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(NDR_NBT_LIBS) \
+ libsss_ldap_common.la \
+ libsss_idmap.la \
+ libsss_krb5_common.la \
+ libsss_ad_common.la \
+ libsss_test_common.la
+
ad_common_tests_SOURCES = \
$(sssd_be_SOURCES) \
src/tests/cmocka/test_ad_common.c