summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 01d199ace..79ab0fda5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -134,6 +134,7 @@ if HAVE_CHECK
ipa_hbac-tests \
sss_idmap-tests \
responder_socket_access-tests \
+ sbus_tests \
sbus_codegen_tests
if BUILD_SSH
@@ -1308,6 +1309,16 @@ krb5_child_test_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+sbus_tests_SOURCES = \
+ src/tests/common_dbus.c \
+ src/tests/sbus_tests.c
+sbus_tests_CFLAGS = \
+ $(CHECK_CFLAGS)
+sbus_tests_LDADD = \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(SSSD_LIBS) \
+ $(CHECK_LIBS)
+
sbus_codegen_tests_SOURCES = \
src/tests/sbus_codegen_tests.c \
src/tests/sbus_codegen_tests_generated.c \