summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 88e29fff4..62f21af6d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -147,7 +147,8 @@ if HAVE_CMOCKA
test-io \
sss_nss_idmap-tests \
dyndns-tests \
- fqnames-tests
+ fqnames-tests \
+ test_sss_idmap
endif
check_PROGRAMS = \
@@ -1298,6 +1299,17 @@ fqnames_tests_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+test_sss_idmap_SOURCES = \
+ $(TEST_MOCK_OBJ) \
+ src/tests/cmocka/test_sss_idmap.c
+test_sss_idmap_CFLAGS = \
+ $(AM_CFLAGS)
+test_sss_idmap_LDADD = \
+ $(CMOCKA_LIBS) \
+ libsss_idmap.la \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
+
endif
noinst_PROGRAMS = pam_test_client