summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9dbde0391..39e6e0745 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,11 @@
+extra_distcheck_flags =
+if HAVE_DEVSHM
+ extra_distcheck_flags += --with-test-dir=/dev/shm
+endif
+
DISTCHECK_CONFIGURE_FLAGS = --with-ldb-lib-dir="$$dc_install_base"/lib/ldb \
- --enable-all-experimental-features
+ --enable-all-experimental-features \
+ $(extra_distcheck_flags)
SUBDIRS = po