summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f490bc39a..d9d41df5f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -154,6 +154,7 @@ if HAVE_CMOCKA
test_utils \
ad_access_filter_tests \
ad_common_tests \
+ dp_opt_tests \
test_search_bases
endif
@@ -1456,6 +1457,17 @@ ad_common_tests_LDADD = \
libsss_krb5_common.la \
libsss_test_common.la
+dp_opt_tests_SOURCES = \
+ src/providers/data_provider_opts.c \
+ src/tests/cmocka/test_dp_opts.c
+dp_opt_tests_CFLAGS = \
+ $(AM_CFLAGS)
+dp_opt_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(TALLOC_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
+
endif
noinst_PROGRAMS = pam_test_client