summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b997e7aa5..e964a2461 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -149,7 +149,8 @@ if HAVE_CMOCKA
sss_nss_idmap-tests \
dyndns-tests \
fqnames-tests \
- test_sss_idmap
+ test_sss_idmap \
+ test_utils
endif
check_PROGRAMS = \
@@ -1354,6 +1355,15 @@ test_sss_idmap_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+test_utils_SOURCES = \
+ $(TEST_MOCK_OBJ) \
+ src/tests/cmocka/test_utils.c
+test_utils_CFLAGS = \
+ $(AM_CFLAGS)
+test_utils_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
endif
noinst_PROGRAMS = pam_test_client