summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 85c754c82..192486670 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -228,7 +228,8 @@ if BUILD_PYTHON_BINDINGS
pyexec_LTLIBRARIES = \
pysss.la \
pyhbac.la \
- pysss_murmur.la
+ pysss_murmur.la \
+ pysss_nss_idmap.la
endif
dist_noinst_SCRIPTS = \
@@ -1750,6 +1751,18 @@ pysss_murmur_la_LIBADD = \
pysss_murmur_la_LDFLAGS = \
-avoid-version \
-module
+
+pysss_nss_idmap_la_SOURCES = \
+ src/python/pysss_nss_idmap.c
+pysss_nss_idmap_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(PYTHON_CFLAGS)
+pysss_nss_idmap_la_LIBADD = \
+ $(PYTHON_LIBS) \
+ libsss_nss_idmap.la
+pysss_nss_idmap_la_LDFLAGS = \
+ -avoid-version \
+ -module
endif
################