summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e12b769ce..3209cbab3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -147,7 +147,8 @@ endif
if HAVE_CMOCKA
non_interactive_cmocka_based_tests = \
nss-srv-tests \
- test-find-uid
+ test-find-uid \
+ test-io
endif
check_PROGRAMS = \
@@ -1233,6 +1234,14 @@ test_find_uid_LDADD = \
$(DHASH_LIBS) \
$(CMOCKA_LIBS) \
libsss_util.la
+
+test_io_SOURCES = \
+ src/tests/cmocka/test_io.c \
+ src/util/io.c
+test_io_CFLAGS = \
+ $(AM_CFLAGS)
+test_io_LDADD = \
+ $(CMOCKA_LIBS)
endif
noinst_PROGRAMS = pam_test_client