summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9927391fe..4e042922d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -216,6 +216,7 @@ if HAVE_CMOCKA
test_sdap_access \
sdap-tests \
test_sysdb_views \
+ test_sysdb_subdomains \
test_sysdb_utils \
test_be_ptask \
test_copy_ccache \
@@ -2235,6 +2236,21 @@ test_sysdb_views_LDADD = \
libsss_test_common.la \
$(NULL)
+test_sysdb_subdomains_SOURCES = \
+ src/tests/cmocka/test_sysdb_subdomains.c \
+ $(NULL)
+test_sysdb_subdomains_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_sysdb_subdomains_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(LDB_LIBS) \
+ $(POPT_LIBS) \
+ $(TALLOC_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ $(NULL)
+
test_sysdb_utils_SOURCES = \
src/tests/cmocka/test_sysdb_utils.c \
$(NULL)