summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0dfd6003d..65595aa06 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -163,6 +163,7 @@ if HAVE_CMOCKA
ad_common_tests \
dp_opt_tests \
responder-get-domains-tests \
+ sbus-internal-tests \
test_search_bases
endif
@@ -1411,6 +1412,27 @@ responder_get_domains_tests_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+sbus_internal_tests_SOURCES = \
+ src/tests/cmocka/sbus_internal_tests.c \
+ src/sbus/sssd_dbus_request.c
+sbus_internal_tests_CFLAGS = \
+ $(AM_CFLAGS)
+sbus_internal_tests_LDFLAGS = \
+ -Wl,-wrap,dbus_bus_get \
+ -Wl,-wrap,dbus_pending_call_steal_reply \
+ -Wl,-wrap,dbus_pending_call_unref \
+ -Wl,-wrap,dbus_message_unref \
+ -Wl,-wrap,dbus_connection_unref \
+ -Wl,-wrap,dbus_connection_set_exit_on_disconnect \
+ -Wl,-wrap,hash_lookup
+sbus_internal_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ libsss_util.la \
+ libsss_crypt.la \
+ libsss_debug.la \
+ libsss_test_common.la
+
test_find_uid_DEPENDENCIES = \
$(ldblib_LTLIBRARIES)
test_find_uid_SOURCES = \