summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c2eaaeee2..d63675dfc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -214,6 +214,7 @@ if HAVE_CMOCKA
test_search_bases \
sdap-tests \
test_sysdb_views \
+ test_be_ptask \
$(NULL)
if BUILD_IFP
@@ -2080,6 +2081,21 @@ test_sysdb_views_LDADD = \
libsss_test_common.la \
$(NULL)
+test_be_ptask_SOURCES = \
+ src/tests/cmocka/test_be_ptask.c \
+ src/providers/dp_ptask.c \
+ $(NULL)
+test_be_ptask_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_be_ptask_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(TALLOC_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ $(NULL)
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client