summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ac8ad1566..60bc67f1a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -215,6 +215,7 @@ if HAVE_CMOCKA
sss_sifp-tests \
test_search_bases \
sdap-tests \
+ test_sysdb_views \
$(NULL)
if BUILD_IFP
@@ -2060,6 +2061,21 @@ sss_sifp_tests_LDADD = \
$(SSSD_INTERNAL_LTLIBS)
endif # BUILD_IFP
+test_sysdb_views_SOURCES = \
+ src/tests/cmocka/test_sysdb_views.c \
+ $(NULL)
+test_sysdb_views_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_sysdb_views_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(LDB_LIBS) \
+ $(POPT_LIBS) \
+ $(TALLOC_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ $(NULL)
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client