summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 434f28f52..ffbdf970a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -220,6 +220,7 @@ if HAVE_CMOCKA
test_child_common \
responder_cache_req-tests \
test_sbus_opath \
+ test_fo_srv \
$(NULL)
if HAVE_LIBRESOLV
@@ -2258,6 +2259,24 @@ test_resolv_fake_LDADD = \
$(NULL)
endif # HAVE_LIBRESOLV
+test_fo_srv_SOURCES = \
+ src/tests/cmocka/test_fo_srv.c \
+ src/providers/fail_over.c \
+ src/providers/fail_over_srv.c \
+ $(NULL)
+test_fo_srv_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_fo_srv_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(TALLOC_LIBS) \
+ $(CARES_LIBS) \
+ $(DHASH_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ $(NULL)
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client