summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 355f8c3d5..c14a50fc3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2175,6 +2175,9 @@ test_child_common_CFLAGS = \
$(AM_CFLAGS) \
-DCHILD_DIR=\"$(builddir)\" \
$(NULL)
+test_child_common_LDFLAGS = \
+ -Wl,-wrap,child_io_destructor \
+ $(NULL)
test_child_common_LDADD = \
$(CMOCKA_LIBS) \
$(POPT_LIBS) \