summaryrefslogtreecommitdiffstats
path: root/sss_client/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-08-20 14:59:13 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-08-20 12:27:13 -0400
commite84e9b5fa2e4352bfc3bfabe55dc57190da7e7d5 (patch)
tree3ecc842582323476fab9f367efd2e329db55d586 /sss_client/Makefile.am
parent806b80ff4dff79a587d5f2fda77a6d27ba664fdb (diff)
downloadsssd-e84e9b5fa2e4352bfc3bfabe55dc57190da7e7d5.tar.gz
sssd-e84e9b5fa2e4352bfc3bfabe55dc57190da7e7d5.tar.xz
sssd-e84e9b5fa2e4352bfc3bfabe55dc57190da7e7d5.zip
Support gettext >= 0.14 instead of 0.17
This is needed for support of RHEL5 Adding the assignment of $(localedir) was necessary, as gettext 0.14 does not include automatically assign it.
Diffstat (limited to 'sss_client/Makefile.am')
-rw-r--r--sss_client/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/sss_client/Makefile.am b/sss_client/Makefile.am
index 7333e4c39..a8228ee1d 100644
--- a/sss_client/Makefile.am
+++ b/sss_client/Makefile.am
@@ -1,11 +1,12 @@
SUBDIRS = po
pipepath=@pipepath@
+localedir = @localedir@
topdir=.
AM_CPPFLAGS = \
-I$(topdir) \
- -DLOCALEDIR=\"\$(localedir)\" \
+ -DLOCALEDIR=\"$(localedir)\" \
-DSSS_NSS_SOCKET_NAME=\"$(pipepath)/nss\" \
-DSSS_PAM_SOCKET_NAME=\"$(pipepath)/pam\" \
-DSSS_PAM_PRIV_SOCKET_NAME=\"$(pipepath)/private/pam\"