summaryrefslogtreecommitdiffstats
path: root/sss_client/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-08-05 14:45:14 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-08-11 12:29:34 -0400
commitb3b55f167063417c285524ba35bd9298965b834a (patch)
tree4c918ec839222dd55d0090d03d27b9b932491c57 /sss_client/Makefile.am
parent28bbb2ec4c5f29339488f07f63f55e5c6657e9a1 (diff)
downloadsssd-b3b55f167063417c285524ba35bd9298965b834a.tar.gz
sssd-b3b55f167063417c285524ba35bd9298965b834a.tar.xz
sssd-b3b55f167063417c285524ba35bd9298965b834a.zip
Make socket paths a compile-time option
Previously, we had hardcoded the paths for the NSS, PAM and private PAM sockets to /var/lib/sss/pipes. With this patch, we will specify the sockets with --with-pipe-path.
Diffstat (limited to 'sss_client/Makefile.am')
-rw-r--r--sss_client/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/sss_client/Makefile.am b/sss_client/Makefile.am
index 4552720ed..7333e4c39 100644
--- a/sss_client/Makefile.am
+++ b/sss_client/Makefile.am
@@ -1,9 +1,14 @@
SUBDIRS = po
+pipepath=@pipepath@
+
topdir=.
AM_CPPFLAGS = \
-I$(topdir) \
- -DLOCALEDIR=\"\$(localedir)\"
+ -DLOCALEDIR=\"\$(localedir)\" \
+ -DSSS_NSS_SOCKET_NAME=\"$(pipepath)/nss\" \
+ -DSSS_PAM_SOCKET_NAME=\"$(pipepath)/pam\" \
+ -DSSS_PAM_PRIV_SOCKET_NAME=\"$(pipepath)/private/pam\"
ACLOCAL_AMFLAGS = -I m4
AM_CFLAGS =