summaryrefslogtreecommitdiffstats
path: root/sss_client/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-07-13 09:12:33 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-07-13 12:13:55 -0400
commit7f5e857a11f932c247b5a96d0d86768226ba2e96 (patch)
tree979dd585dbcc4d4405cf64b915ee944268d59712 /sss_client/Makefile.am
parentc26fd1ebd626a01f9c56796c64f6824525d77085 (diff)
downloadsssd-7f5e857a11f932c247b5a96d0d86768226ba2e96.tar.gz
sssd-7f5e857a11f932c247b5a96d0d86768226ba2e96.tar.xz
sssd-7f5e857a11f932c247b5a96d0d86768226ba2e96.zip
Build all SSSD components with warnings enabled
Previously, only the SSSD server components were being built with compile-time warnings enabled. This patch will ensure that all components in common and sss_client are also built the same way.
Diffstat (limited to 'sss_client/Makefile.am')
-rw-r--r--sss_client/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/sss_client/Makefile.am b/sss_client/Makefile.am
index 346e6b1d4..4552720ed 100644
--- a/sss_client/Makefile.am
+++ b/sss_client/Makefile.am
@@ -11,6 +11,11 @@ if WANT_AUX_INFO
AM_CFLAGS += -aux-info $@.X
endif
+if HAVE_GCC
+ AM_CFLAGS += -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith \
+ -Wcast-qual -Wcast-align -Wwrite-strings
+endif
+
nsslibdir = @nsslibdir@
pamlibdir = $(nsslibdir)/security