summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-03-10 10:47:26 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-03-12 09:00:28 -0500
commitb1798ddcfb952efb7cc8bacaf51b3486a7fec121 (patch)
tree31ee1eccee1247c0c71f66fb99ce83b5f83021ac /src/configure.ac
parent03e7e62d439a2ef21f3c1c074a593a15606a0e1e (diff)
downloadsssd-b1798ddcfb952efb7cc8bacaf51b3486a7fec121.tar.gz
sssd-b1798ddcfb952efb7cc8bacaf51b3486a7fec121.tar.xz
sssd-b1798ddcfb952efb7cc8bacaf51b3486a7fec121.zip
Fix build when check-devel is not installed
tests/common.c is now required by all tests (check-based and not), so we need to properly ifdef it
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index d7a7a7705..da718eefa 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -135,6 +135,8 @@ AC_CHECK_HEADERS([sasl/sasl.h],,AC_MSG_ERROR([Could not find SASL headers]))
PKG_CHECK_MODULES([CHECK], [check >= 0.9.5], [have_check=1], [have_check=])
if test x$have_check = x; then
AC_MSG_WARN([Without the 'CHECK' libraries, you will be unable to run all tests in the 'make check' suite])
+else
+ AC_CHECK_HEADERS([check.h],,AC_MSG_ERROR([Could not find CHECK headers]))
fi
AC_PATH_PROG([DOXYGEN], [doxygen], [false])