summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-02-26 09:04:11 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-03-04 12:41:30 -0500
commit9fb59763bce293c2490e0b9f8e97bb1f74ba0910 (patch)
treebebd5ddc3975da122a34a09a5781b26025b96720 /src/configure.ac
parent07a2e0b66a1c4688825e07fa88d37886fec4770c (diff)
downloadsssd-9fb59763bce293c2490e0b9f8e97bb1f74ba0910.tar.gz
sssd-9fb59763bce293c2490e0b9f8e97bb1f74ba0910.tar.xz
sssd-9fb59763bce293c2490e0b9f8e97bb1f74ba0910.zip
Add --with-test-dir option to configure
All 'make check' tests will chdir() into this directory before running the suite. This provides the option of having temporary files generated in a tmpfs or ramdisk
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 4198ee952..d7a7a7705 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -65,6 +65,7 @@ WITH_PUBCONF_PATH
WITH_PIPE_PATH
WITH_INIT_DIR
WITH_SHADOW_UTILS_PATH
+WITH_TEST_DIR
WITH_MANPAGES
WITH_XML_CATALOG
WITH_KRB5_PLUGIN_PATH
@@ -141,5 +142,8 @@ AM_CONDITIONAL([HAVE_DOXYGEN], [test x$DOXYGEN != xfalse ])
AM_CONDITIONAL([HAVE_CHECK], [test x$have_check != x])
+abs_build_dir=`pwd`
+AC_DEFINE_UNQUOTED([ABS_BUILD_DIR], ["$abs_build_dir"], [Absolute path to the build directory])
+
AC_CONFIG_FILES([Makefile doxy.config po/Makefile.in])
AC_OUTPUT