summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-03-30 15:26:58 +0200
committerStephen Gallagher <sgallagh@redhat.com>2010-04-08 08:53:35 -0400
commit9c124af8868a7d3908c03ec369e28daef17d5f12 (patch)
tree2efdddd72acb1d48941c2ee9749c6ad7cadb8697 /src/configure.ac
parent81020661d35772b5499525b76a19c9a3794c953e (diff)
downloadsssd-9c124af8868a7d3908c03ec369e28daef17d5f12.tar.gz
sssd-9c124af8868a7d3908c03ec369e28daef17d5f12.tar.xz
sssd-9c124af8868a7d3908c03ec369e28daef17d5f12.zip
SELinux login management
Adds a new option -Z to sss_useradd and sss_usermod. This option allows user to specify the SELinux login context for the user. On deleting the user with sss_userdel, the login mapping is deleted, so subsequent adding of the same user would result in the default login context unless -Z is specified again. MLS security is not supported as of this patch.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 52162b7c6..40dac37ce 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -72,6 +72,7 @@ WITH_KRB5_PLUGIN_PATH
WITH_PYTHON_BINDINGS
WITH_SELINUX
WITH_NSCD
+WITH_SEMANAGE
m4_include([external/platform.m4])
m4_include([external/pkg.m4])
@@ -130,6 +131,10 @@ if test x$HAVE_SELINUX != x; then
AM_CHECK_SELINUX
fi
+if test x$HAVE_SEMANAGE != x -a x$HAVE_SELINUX != x; then
+ AM_CHECK_SEMANAGE
+fi
+
AC_CHECK_HEADERS([sys/inotify.h])
AC_CHECK_HEADERS([sasl/sasl.h],,AC_MSG_ERROR([Could not find SASL headers]))