summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-07-23 16:23:57 -0400
committerStephen Gallagher <sgallagh@redhat.com>2010-08-03 13:54:38 -0400
commitdbd09f5703d721a58210e490609cfacb7eb56fcf (patch)
tree53c150f58f595150236239d8ca21c291d00cb42c /src/Makefile.am
parent0286d59c82657abe96ccaa3eebea7240ac30ca81 (diff)
downloadsssd-dbd09f5703d721a58210e490609cfacb7eb56fcf.tar.gz
sssd-dbd09f5703d721a58210e490609cfacb7eb56fcf.tar.xz
sssd-dbd09f5703d721a58210e490609cfacb7eb56fcf.zip
Add diff_string_lists utility function
Includes a unit test
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2e4413e5e..82f0981b3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -82,7 +82,8 @@ if HAVE_CHECK
find_uid-tests \
auth-tests \
ipa_ldap_opt-tests \
- simple_access-tests
+ simple_access-tests \
+ util-tests
endif
check_PROGRAMS = \
@@ -682,6 +683,17 @@ simple_access_tests_LDADD = \
$(SSSD_LIBS) \
$(CHECK_LIBS)
+util_tests_SOURCES = \
+ tests/util-tests.c \
+ $(SSSD_UTIL_OBJ)
+util_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(CHECK_CFLAGS)
+util_tests_LDADD = \
+ $(SSSD_LIBS) \
+ $(CHECK_LIBS) \
+ libsss_test_common.la
+
endif
stress_tests_SOURCES = \