summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-06-27 21:22:11 +0200
committerStephen Gallagher <sgallagh@redhat.com>2010-07-09 11:44:07 -0400
commit90acbcf20b5f896ca8f631923afe946c90d90de7 (patch)
treea4942121f0c624d1ea6f16bf093924fade010b88 /src/Makefile.am
parent801fcc63a9ec83d76d8d027758f9a0357b34890f (diff)
downloadsssd-90acbcf20b5f896ca8f631923afe946c90d90de7.tar.gz
sssd-90acbcf20b5f896ca8f631923afe946c90d90de7.tar.xz
sssd-90acbcf20b5f896ca8f631923afe946c90d90de7.zip
Use netlink to detect going online
Integrates libnl to detect adding routes. When a route is added, the offline status of all back ends is reset. This patch adds no heuristics to detect whether back end went offline. Fixes: #456
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c80409c87..64e0e081a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -202,6 +202,7 @@ AM_CPPFLAGS = -Wall \
$(COLLECTION_CFLAGS) \
$(INI_CFG_CFLAGS) \
$(DHASH_CFLAGS) \
+ $(LIBNL_CFLAGS) \
-DLIBDIR=\"$(libdir)\" \
-DVARDIR=\"$(localstatedir)\" \
-DSHLIBEXT=\"$(SHLIBEXT)\" \
@@ -374,10 +375,12 @@ dist_noinst_HEADERS = \
####################
sssd_SOURCES = \
monitor/monitor.c \
+ monitor/monitor_netlink.c \
confdb/confdb_setup.c \
$(SSSD_UTIL_OBJ)
sssd_LDADD = \
- $(SSSD_LIBS)
+ $(SSSD_LIBS) \
+ $(LIBNL_LIBS)
sssd_nss_SOURCES = \
responder/nss/nsssrv.c \