summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2010-04-15 18:26:18 +0200
committerStephen Gallagher <sgallagh@redhat.com>2010-04-26 09:55:00 -0400
commit5b680ac8ef46fc1714f2ab59a07f68ac386ad89b (patch)
tree5bbf5788a17b5e6e5091430793b4adaef59b0df3 /src/Makefile.am
parent74ff3d42d38feab9aaf1db86f228c41418b8b592 (diff)
downloadsssd-5b680ac8ef46fc1714f2ab59a07f68ac386ad89b.tar.gz
sssd-5b680ac8ef46fc1714f2ab59a07f68ac386ad89b.tar.xz
sssd-5b680ac8ef46fc1714f2ab59a07f68ac386ad89b.zip
Make the handling of fd events opaque
Depending on the version of the OpenLDAP libraries we use two different schemes to find the file descriptor of the connection to the LDAP server. This patch removes the related ifdefs from the main code and introduces helper functions which can handle the specific cases.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e56d7b166..92244f4a4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -722,6 +722,7 @@ libsss_ldap_la_SOURCES = \
providers/ldap/sdap_async_accounts.c \
providers/ldap/sdap_async_connection.c \
providers/ldap/sdap_child_helpers.c \
+ providers/ldap/sdap_fd_events.c \
providers/ldap/sdap.c \
util/user_info_msg.c \
util/sss_ldap.c \
@@ -793,6 +794,7 @@ libsss_ipa_la_SOURCES = \
providers/ldap/sdap_async_accounts.c \
providers/ldap/sdap_async_connection.c \
providers/ldap/sdap_child_helpers.c \
+ providers/ldap/sdap_fd_events.c \
providers/ldap/sdap.c \
util/user_info_msg.c \
util/sss_ldap.c \